Incorrect Reporting of Ad Hoc Email Marketing Campaign Metrics
Incident Report for Orbee
Resolved
All data has been reprocessed for the outage period. On top of that, new account onboarding no longer shows any issues setting up campaign event webhooks.

All operations and reporting is back to normal.
Posted May 23, 2023 - 07:38 PDT
Monitoring
The issue has been identified as a change made to our email service provider's onboarding APIs and processed and has been remediated. Any future campaigns will report stats correctly.

The issue only affected a small subset of new customers and does not have any impact on the vast majority of customers using our email products.

The issue affected our collection of email events from our email service provider. These events can be retrieved and reprocessed, and we are now going through that process. We will provide an update once this process is underway and we can share a timeline for remediation.
Posted May 16, 2023 - 13:51 PDT
Investigating
We are currently investigating an incident that has been identified in relation to campaign metrics, which are not displaying accurately in the platform. Our team is fully aware of this issue, and our engineers are working to identify the root cause of the problem and resolve it as quickly as possible.

This incident is causing a number of metrics including delivered, unique opens, unique clicks, unsubscribed, marked spam, and bounced metrics, to either report as 0 results or inaccurately. Our team is committed to resolving this issue as quickly and efficiently as possible.

While our engineering team works on resolving this issue, we can provide the affected metrics manually via a spreadsheet. Our success team is available to assist you with your requests.

We will continue to share updates on the status of this incident, as we have more information.
Posted May 12, 2023 - 13:54 PDT
This incident affected: Email Marketing.