Login Issues
Incident Report for Orbee
Resolved
The login issue has been resolved. All users should now be able to access the platform. Thank you for your patience as we resolved this issue.
Posted Sep 30, 2024 - 10:58 PDT
Investigating
We are aware of an issue affecting some users' ability to log in to the Orbee platform. We are investigating the cause and working to restore access as quickly as possible.
Posted Sep 30, 2024 - 10:34 PDT
This incident affected: Platform.