Inaccurate Delivered & Bounced Reporting for Ad Hoc Email Campaigns
Incident Report for Orbee
Resolved
We have applied a fix that reconciles stats every hour for 7 days after the initial send.

We have verified this is working and email campaign stats are accurate.
Posted May 03, 2023 - 10:02 PDT
Identified
The issue has been identified as a real-time event duplication issue when receiving events from our Email Provider.

To remediate the issue, we are manually addressing inaccuracies in the meantime; however, we are implementing an automated resolution of email stats on an hourly basis to maintain accurate statistics.

More details to come soon as the fix is implemented and deployed.
Posted Apr 04, 2023 - 09:09 PDT
Investigating
We are currently investigating an issue related to our ad hoc email campaign reporting, which may cause inflated results for the Delivered and Bounced metrics in some accounts. Our team of engineers has been notified and is working to identify the root cause of the issue.

We understand the importance of accurate reporting for our customers, and we are committed to providing you with reliable reporting. We will continue to keep you informed throughout the investigation and provide updates on our progress.

This issue does not affect the delivery of your email campaigns. Your campaigns are being delivered as expected, and we are working to ensure that our reporting accurately reflects the actual delivery results.
Posted Mar 30, 2023 - 09:28 PDT
This incident affected: Email Marketing.