Data Processing Delays - Reporting Tools Affected

Incident Report for Orbee

Resolved

This incident has been resolved.
Posted Dec 16, 2025 - 15:26 PST

Monitoring

We have implemented a fix and we are monitoring the results.
Posted Dec 11, 2025 - 17:59 PST

Investigating

Our data processing infrastructure is running behind which is causing delays in our audience building tool and by extension is impacting email marketing tools. Uploading third-party lists is still available as an option to add create email marketing audience.
Posted Dec 11, 2025 - 10:32 PST
This incident affected: Advertising and Email Marketing.